Symptom
An attachment in a document, for example a customer invoice request, is not accessible. When clicking on the hyper link for the attachment, a small white box and no image appears. It is required to press the Download button to view the image.
Environment
SAP Business ByDesign
Reproducing the Issue
The following example relates to a customer invoice, but this could occur in the attachments of any document.
1. Open the work center Customer Invoicing > Invoice Requests
2. Search for invoice request ABC (where ABC is the ID of the invoice request)
3. Click Edit/View All
4. Navigate to the General tab
5. Click the Attachments sub-tab
6. Click the attachment hyperlink
A small white box appears instead of the image. When downloading the image it appears normally.
Cause
The original jpg file was saved with a Tiff compression (Compression LZW) which can also be seen in the properties of the jpg file. When encoding this and uploading it as an attachment, it is not possible to open it by clicking on the hyperlink for the attachment in the browser.
Resolution
This is the current behavior provided by SAP Business ByDesign.
To solve the issue, please ensure that none of the jpg files that shall be attached are saved with a Tiff compression (Compression LZW). When uploading a document via web service, in order to upload a jpg or other file, it is required to encode this to a base64 format. For example, this can be done via through web resources that convert images to base64 format.
It is then required to copy the encoded text and past it in the tag <BinaryObject>xxx</BinaryObject> (where xxx is the encoded text).
Keywords
small white box, not available, no image, not showing , KBA , SRD-CRM-INV , Customer Invoicing , Problem