Symptom
- You have configured workflow conditions to be triggered only when certain patterns are not match, for example, in the case of an inbound e-mail
- The expectation is that the workflow should only be triggered when the subject does not match the pattern maintained in the workflow
Environment
- SAP Cloud for Service
- SAP Cloud for Sales
- SAP Cloud for Customer
Reproducing the Issue
- Create a workflow to send e-mail notification
- Configure the workflow conditions and use the:
- "Conditions Met" criteria
- Rule Type = E-mail
- Timing = On Create Only
- Under General Data add whatever is relevant for your business and set the Subject(s) to something like:
- Does not match = Auto Response
- Does not match = Out or Office
- Continue the configuration and activate the WF
- Send an e-mail to the corresponding e-mail channel defined under the "Sender Information" section in the workflow
- The e-mail should have the same patterns defined above
- If the e-mail channel has been configured correctly, a ticket should be created
- Check the workflow log from the ticket that was generated
Cause
- multiple possible causes
- overlapping conflicts with other workflows (potentially)
- configuration issue
Resolution
- In some case, the easiest option is to add wildcards to the start and the end of the pattern(s) defined.
- In the above example we recommend adding the "*" infront and after the subject.
- For example:
- Does not match = *Auto Response*
- Does not match = *Out or Office*
- If the problem happens in production; create the same workflow in a test environment and test it.
- Ensure the order
- Ensure the criteria is exactly the same
See Also
- 2943939 - How To Configure Workflow To Send E-Mails To Delegate Of The Recipient
- 3096420 - Workflow e-mail Sent to Wrong User
- 2855065 - Workflow Rule not Working
- 2829595 - E-mail Content in Workflow Rules
- 2559649 - Adding Attachments to Workflow Created e-mail
- 2458817 - Scheduled Workflow Rule to Trigger an E-Mail After a Defined Duration Does Not Work
- 2710053 - Workflow Rule Notification cannot be Triggered.
Keywords
E-mail notification, Workflow, User got multiple notification which should not , KBA , LOD-CRM-SRP , Service Request Processing , LOD-CRM-WKF , Workflow , Problem
Product
SAP Cloud for Customer core applications 2202