Symptom
You created a Service Confirmation from a Contract and added the Service of Item Type Service – Fixed Price. When maintaining the Start Date/Time and End Date/Time for the Item and select no Time Zone, the Time Zone is displayed as UTC. When you the add an Actual Duration or change the Working Conditions the Start Date/Time and End Date/Time is converted to the users time zone.
Environment
SAP Business ByDesign
Reproducing the Issue
The logged on user has a different Time Zone than UTC.
In our example the user has the Time Zone EET maintained.
- Go to the Sales Orders work center.
- Select the Contracts view.
- Select Contract XYZ (XYZ Represents the ID of the Contract).
- Click on the Confirm Execution button.
- In the New Service Confirmation go to the Service and Spare Parts tab.
- Click on Add Row.
- Click on the value help of the Product ID field.
- Select Service ABC (ABC represents the service ID).
- Go to the Time Reporting sub tab.
- The Start Date/Time, the End Date/Time and the Actual Duration is not determined automatically by the system and hence the fields are empty.
- In the Start Date/Time, select a date and time and no time zone e.g. 26.05.2022 10:00 AM
- You can see that after the selection the Time Zone in the field will be displayed in UTC
- In the End Date/Time, select a date and time and no time zone e.g. 26.05.2022 11:00 AM
- You can see that after the selection the Time Zone in the field will be displayed in UTC
- Now select a value in the Working Condition field or enter an Actual Duration e.g. 1 hours
The Start Date/Time is converted to the users time zone e.g if the users time zone is EET it will be converted to 26.05.2022 01:00 PM EET and the End Date/Time will be converted to e.g. 26.05.2022 02:00 PM EET
Cause
The issue occurs because the item is of item type Service – Fixed Price (SERV) and:
- the Unit of Measure is not a time based UoM e.g. EA
- there is no Quantity Conversion maintained in the Service Master Data from this UoM to a time based Unit of Measure
- there is no Actual Duration maintained in the Service Confirmation for this item.
In this case the Start Date/Time, the End Date/Time and the Actual Duration is not determined and hence the fields are empty.
Resolution
To solve this issue, you can either ensure that you have a quantity conversion from EA to the respective time based unit of measure (e.g. Hour(s)) or you can ensure that you select the Time Zone of the user e.g. EET when selecting the Start Date/Time and End Date/Time and then maintain the actual duration accordingly.
Keywords
Time Zone; Service Confirmation; Change; Start Date; Actual Duration; UTC; changing time zone; quantity conversion; Service; Fixed Price; unit of measure; UOM , KBA , SRD-CRM-SEO , Service Orders , Problem