SAP Knowledge Base Article - Public

3208108 - Business Partner is not identified in the Agent Desktop when a call arrives

Symptom

  • You are using the new Agent Desktop add-on
  • When an inbound call is alerted in the widget, the customer is not identified 

    Image/Data is from SAP internal systems, sample data, or demo systems.  Any resemblance to real data is purely coincidental.

Environment

  • SAP Cloud for Customer
  • SAP Cloud for Service
  • SAP Cloud for Sales
  • Sinch Contact Pro or other CTI vendors

Reproducing the Issue

  1. Perform and inbound call
  2. Accept the call from the widget

Cause

Missing configuration

Resolution

  1. Ensure the "Customer Search" ID settings have been correctly defined
    • Configure the fields that appear in the agent desktop to identify customers, contacts, and tickets
    • Procedure:
      1. Go to: Administrator > Service and SocialConfigure Agent Desktop
      2. Select Identification Settings
      3. Select the business object for which you want to configure the display fields:
        • Account
        • Contact
        • Individual Customer
        • Ticket
      4. Edit the table to configure the fields displayed in the agent desktop
        table.png
  2. Unless your CTI is using Call Attached Data to push other specific contact information like BP ID, Ticket etc, the system will typically use the Automatic Number Identification (ANI).
    • If the BP identification is using ANI, ensure the BP you are trying to identify has the correct/same phone number maintained.
    • For example, the phone number calling is +1234567890, and the customer is Johnny Bravo.
      • In such a case, you will need to make sure the same BP (Individual Customer, Account or Contact) has the same phone number maintained.
      • One can perform a manual search in the Agent Desktop and/or under the Customers Work Center as a test.
      • See KBA 2880002 for more details

        See Also

        2880002 - Customer account information is not shown in C4C Live Activity when the call notification is received in C4C

        Keywords

        Agent desktop, no identification, unknown customer, C4C , KBA , wrong customer identification , LOD-CRM-LA , Live Activity , Problem

        Product

        SAP Cloud for Customer core applications 2205