SAP Knowledge Base Article - Public

3208415 - Push language packs to i18n management exception

Symptom

Uploading a custom language pack fails

Environment

SAP SuccessFactors HXM Suite

Reproducing the Issue

Create a new custom language pack for any enabled language or download and edit an existing custom pack

Any mistake in the file will cause this error on upload

Some examples of possible mistakes are

  • Leaving the Key column empty while trying to maintain a translation for the same line
  • Mixing the key and translations columns up - adding the translation to the Key column and/or add the key to the translation column
  • We recommend you edit the file in a text editor - if you miss a separator (comma) 
  • Save the file with the mistake and upload - error received 

Cause

The file you are uploading will fail if there is a mistake in it and the system cannot read it correctly

Resolution

  • Review the custom file and double check there are no mistakes
  • Ensure all keys are correct and exist in the default pack
  • Ensure all lines are correctly maintained with the correct key and translation
  • If editing or uploading as a text file, ensure all keys are separated from their translations by a comma and that all keys and translations have the correct opening and closing double quotes

See Also

KBA - 2576546 - Using the Manage Language Feature to Change Labels in SuccessFactors

Keywords

Manage Language, Custom Language, Custom Pack, Push language packs to i18n management exception, i18n , KBA , LOD-SF-PLT-LAN , Manage Language & Text Replacements , Problem

Product

SAP SuccessFactors Platform all versions