Symptom
You would like to know if it is possible to export the Deleted Data in Cloud for Customer (C4C).
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Administrator Workcenter.
- Go to General Settings view.
- Click Data Management.
- Go to Deleted Data.
- You can see that there is no option to export it.
Cause
Once the data is deleted from the C4C, it's not possible to retrieve (or access) the data anymore. SAP also cannot revert the status back once it is deleted, the status is permanent and it's not possible to retrieve the data.
Also, the screen related to the Deleted Data (under General Settings) is not extended in the OData service.
Resolution
The option to export the Deleted Data would be a New Feature Request.
This is the current expected behavior of SAP Cloud for Customer.
- If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder.
- If you are a customer:
- Contact your Account Executive. Check the link: https://www.sap.com/services/innovation.html#contact-us.
An alternative option may be to check the SAP Cloud for Customer Influence Site to submit an idea.
See Also
2586849 - It Is Not Possible To Restore Deleted Data Or View The Data The Object Contained
Keywords
Delete ; Export ; Download ; Access ; Data ; C4C , KBA , LOD-CRM-OPP , Opportunity Management , LOD-CRM-INT-API , OData API (C4C Only) , How To