Symptom
Employee time object has a custom field with a picklist associated with it. The picklist is sorted alphabetically in the desktop application. But, in the mobile application the values in the picklist are not sorted.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors Employee Central : Time Off
- SAP SuccessFactors Employee Central : Mobile Application
Reproducing the Issue
- Configure a custom field in employee time object with a picklist associated with it
- The picklist should be sorted in alphabetical order in picklist center:
- Open mobile application (both Android and iOS) as an employee
- Go to time off and create a new request
- Select the custom field with picklist associated with it
- The field values are not sorted alphabetically, even though the same values appear in alphabetical order in desktop application
- Desktop
- Mobile:
- Desktop
Cause
The picklist values are retrieved by the mobile application in a different way as compared to desktop. Hence the values are not sorted in the mobile application. This is currently a gap in the mobile functionality.
Resolution
- There is an enhancement request MOB-78478 to enhance the current behavior.
- Currently there is no fix date available for it.
- Once it is implemented, it will be included in release notes.
- You may call SAP hotline number or contact your CSM to know current status of this enhancement request.
Keywords
MOB-39093, Time off, Mobile, picklist, sort, alphabetical, order, custom field, Android, iOS, Employee Central , KBA , LOD-SF-EC-TIM-MOB , Time Mobile , Problem
Product
Attachments
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