Symptom
Attachment in Customer Return is removed if an preceding document is changed e.g. the Warehous task is completed or the Inbound Delivery is unreleased and then released again.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Orders work center.
- Select the Returns view.
- Open Return XYZ (XYZ represents the ID of the Return).
- Navigate to the Attachments tab.
- Add an attachment and saved the changes in the Return.
We are using the example of unreleasing and releasing the Inbound Delivery:
- Go to the Inbound Logistics work center.
- Select the Inbound Delivery view.
- Open Inbound Delivery ABC (ABC represents the ID of the Inbound Delivery the Return is based on).
- Click on the Undo Release button, saved the changes and then click on the Release button.
This removed the Attachment from the Return XYZ:
- Go to the Sales Orders work center.
- Select the Returns view.
- Open Return XYZ.
- Navigate to the Attachments tab.
- You can see that the Attachment is not visible anymore.
Cause
We have taken this up in our product backlog to be solved in a future release.
Resolution
In the meantime you need to manually add the Attachment again in the Return.
Keywords
Customer Return; Return; Attachment; missing; removed; , KBA , AP-CRP , Customer Return Processing , Problem
Product
SAP Business ByDesign 2022 ; SAP Business ByDesign 2205 ; SAP Business ByDesign 2208