Symptom
For a specific analytic application with a complex design, when you open it with the edit mode, the Chrome window crashes after some time.
- Aw, Snap!
Something went wrong while displaying this webpage.
Error code: Out of Memory - If you open this application with the Chrome developers tool (F12) opened and filter requests with "GetResponse" in the Network tab, you will see hundreds of requests (near 100 or more "GetResponse" calls are related to the data queries.)
- It is possible that the issue happens in one of your SAC tenants but does not happen with the same application in other tenants.
Environment
- SAP Analytics Cloud 2022.8.7
Reproducing the Issue
- Open an analytic application in the edit mode.
- Navigate in it or just wait without any UI interaction.
Cause
This application is too complex. For example, if you check in the Chrome developer tools, you observe one or more following cases:
- Hundreds of MB client request resources.
- Hundreds of requests. (~100 "GetResponse" calls are related to the data query.)
- Some query requests take long with relatively huger response data than other normal requests. (For example, maybe some privilege change, more data could be queried than before. Such kinds of huge query data should be reduced.)
Resolution
Short term solution is to increase the default chrome memory limit (for example,"C:\Program Files\Google\Chrome\Application\chrome.exe" --js-flags="--max-old-space-size=8192" ) and reduce the data volume on your tenant. But there will still be some potential risk for chrome out of memory.
- reducing the widgets number
- reducing requests number(delay widget initialization/lazy loading if unnecessary)
- filtering data (limit data size in each query).
Please have a deeper look into the newest version of SAP Analytics Cloud, analytics designer Developer Handbook -> Chapter 14. Performance Best Practices
See Also
- 2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?
- 2728183 - SAP Analytics Cloud (SAC) releases and release information
- 2511489 - Troubleshooting performance issues in SAP Analytics Cloud.
- Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge!
- 2487011 - What information do I need to provide when opening an incident for SAP Analytics Cloud?
- Search for SAP Analytics Cloud content using Google or Bing:
- https://www.google.ca/search?q=site%3Ahttps%3A%2F%2Fapps.support.sap.com+SAP+Analytics+Cloud
- https://www.bing.com/search?q=site%3Ahttps%3A%2F%2Fapps.support.sap.com+SAP+Analytics+Cloud
- Note: Add relevant text or warning/error messages to the text search field to filter results.
- SAP Analytics Cloud Connection Guide
- Getting Started with SAP Analytics Cloud Expert Community page
- SAP Analytics Cloud Get More Help and SAP Support
- Need More Help? Contact Support or visit the solution finder today!
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Keywords
application, analysis, APIs, components, script, analytic design, analytics, outofmemory, crash, crashes, crashing, editor, web browser , KBA , LOD-ANA-AD , Analytics Designer , Problem