Symptom
It is desired to populate the Email and Phone in Address Independent section, but the fields are not displayed in Utilities Communication Data facet for Individual Customers BO.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Customers > Individual Customers.
- Open an Individual Customer.
- See Phone and Email fields are filled.
- Now go to Utilities Communication Data facet.
- See the Phone and Email are not maintained in their respective sections.
Cause
In the Cloud for Customer system, the Telephone, Mobile Phone, Fax and E-mail details on the Account / Individual Customer TI will be considered as an Address Dependent Communication Data. The address which shows on TI is as of today, a valid standard address along with the main communication data.
For the Address Independent Communication Data, the specific tab Utilities Communication Data is available in C4C. This tab will show the address independent communication data via synchronous calls. If the requirement is to use such data, then the required web service needs to be used and configured in C4C, CPI/PI and in S4.
The Phone and E-mail fields from QC (quick create) screen which is displayed in header, is not related to the Address Independent Phone Number and Email address in the Utilities Communication Data tab.
The Address Independent Phone Number and Email address in the Utilities Communication tab for both Accounts and Individual Customers cannot be added to the QC screen.
Resolution
Therefore, the Phone and Email cannot be added as Independent Address and need to be maintained manually inside the Utilities Communication Data facet.
This is the expected system behavior.
Keywords
Person, not showing, not populating, not displaying , KBA , LOD-CRM-IND-UTL , Utilities , How To