Symptom
- Error found in Business Process tile like:
- An error occurred while saving the HRIS data for the user XXX XXX due to the following reason: {"responsePayload":[{"userSysId":"XXXX","hrisSaveStatus":[{"elementType":null,"key":null,"statusCode":"ERROR","errorInfo":"PayComponent - XXX : frequency cannot be empty for pay component XXX."}]}]}.
- Check suite integration page to see that value and mapping is maintained in RCM.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Go to recruit to hire data mapping
- Go to payComponentRecurring
- See that the value is mapped.
- Go to Recruiting.
- Ensure the relevant recruiting field which the frequency is mapped to is filled in.
- Initiate onboarding from recruiting.
- See the error "An error occurred while saving the HRIS data for the user XXX XXX due to the following reason: {"responsePayload":[{"userSysId":"XXXX","hrisSaveStatus":[{"elementType":null,"key":null,"statusCode":"ERROR","errorInfo":"PayComponent - XXX : frequency cannot be empty for pay component XXX."}]}]}." in BPE.
Cause
RCM is not sending the frequency ID.
Resolution
- Frequency is an object, therefore, the ID for the object needs to be passed not the label.
- Please go to Manage Organization, Pay and Job Structures and find the Frequency ID for the object.
- Following this, Please go to recruiting and enter the frequency ID instead of the label for the object.
Keywords
payComponentRecurring, frequency, BPE error, recruiting, onboarding, missing values, Pay Comp, pay component, mapping, incorrect mapping, frequency ID, label , KBA , LOD-SF-OBX-RCM , Initiate onboarding from RCM , Problem
Product
SAP SuccessFactors Onboarding
SAP Knowledge Base Article - Public