Symptom
Error found in Business Process tile like:
An error occurred while saving the HRIS data for the user XXX XXX due to the following reason: {"responsePayload":[{"userSysId":"XXXX","hrisSaveStatus":[{"elementType":null,"key":null,"statusCode":"ERROR","errorInfo":"PayComponent - XXX :: frequency cannot be empty for pay component XXX."}]}]}.
Checked suite page and value and mapping is maintained in RCM.
Environment
SAP SuccessFactors Onboarding
Cause
RCM is sending picklist value to frequency.
Resolution
Frequency is an object.
Please go to Manage Organization, Pay and Job Structures and find the Frequency used.
Make sure RCM is sending Frequency ID.
Keywords
payComponentRecurring , KBA , LOD-SF-OBX-RCM , Initiate onboarding from RCM , Problem