Symptom
- You are experiencing UI or performance issues while accessing SAP Cloud for Customer (Sales or Service)
- Support has requested you to capture and provide traces to help with further analysis
- This KBA provides the basic steps required to enable traces for HTTPWatch, Google Chrome or Microsoft Edge
Image/Data is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP Cloud for Customer
- SAP Cloud for Sales
- SAP Cloud for Service
Cause
Logs required for further analysis
Resolution
- Steps to enable and collect HTTPWatch
- Open Chrome (or Edge) Developer Tools from the menu (under Menu (...) > More tools > Developer tools) or by pressing Ctrl+Shift+C (or the F12 function key) on your keyboard when browser is in focus.
- Go to the Network Tab and make sure that the circle in the top-left corner is red, if it is gray, click it to start recording.
- Clear the log by clicking the circle with the line through it.
- Click the check boxes Preserve log and Disable cache.
- Reproduce the issue or performance problem by performing all the steps when the issue or error is observed.
- Note: Creating a video at the same time is recommended.
- Describe (in the case) the high level steps performed.
- When you have finished reproducing the workflow, click the top left recording button to stop recording (see screenshot).
- Right click the requests grid and click Save as HAR with content.
- Attach the HAR file to the case.
- Enable and collect logs in Chrome
- Open the main Chrome menu
- Select More Tools > Developer Tools
- Depending on which logs you need, you'll select the Network or Console Tab to get the logs you need.
- Sometimes we may ask you to enable the DevTools for a popup window (such as when troubleshooting connected accounts). To do this in Chrome:
- Open the Developer Tools as above
- Navigate to the Settings page
- Enable Auto-open DevTools for popups (don't forget to disable it when you're done troubleshooting!).
- Enable and collect logs in MS Edge
- Open the Edge menu on the top-right of your browser ... (3 dots) and choose More tools
- Select Developer tools
- Right-click anywhere inside of the screen circled in red and choose to Save as. Your browser will prompt you to save a “.log” file.
- Attach this .log file in the SAP Support case and sent it back to Support with the steps taken
Keywords
Troubleshoot, Chrome, Console, Performance, UI, User Interface , KBA , LOD-CRM-SRP , Service Request Processing , AP-RC-UIF , C4C UI Framework , Problem
Product
SAP Cloud for Customer core applications 2205