SAP Knowledge Base Article - Public

3212121 - Error While Migrating Customers: "Number Range Depleted"

Symptom

You are trying to migrate new customers using the migration tool in business configuration, but the migration of some of the records fails with error message "Number range depleted".

This happens although their IDs meet the external number range, and other records with IDs of the same range don't show the error.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Business Configuration
  2. Go to Overview
  3. Select Migration of Customers activity
  4. Select Migrate Customers using the Migration Tool
  5. Select the related file
  6. Migrate step by step
  7. At Simulation or Import step, find error: "Number range depleted"

Cause

The external number range is relevant for accounts. The issue might be caused by the fact that some of the records are related to contacts, and IDs of contacts are always pulled from the internal number range. This range is exhausted.

Resolution

  1. Go to Business Configuration
  2. Go to Overview
  3. Search for Number Ranges and there for General Business Partners
  4. Maintain the Internal number range  to be sufficiently large, but without intersecting with the other ranges

Keywords

migrate, Customer, Customers, account, import, migration , KBA , SRD-MD-BP , Business Partner , How To

Product

SAP Business ByDesign all versions