Symptom
You are trying to migrate new customers using the migration tool in business configuration, but the migration of some of the records fails with error message "Number range depleted".
This happens although their IDs meet the external number range, and other records with IDs of the same range don't show the error.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Business Configuration
- Go to Overview
- Select Migration of Customers activity
- Select Migrate Customers using the Migration Tool
- Select the related file
- Migrate step by step
- At Simulation or Import step, find error: "Number range depleted"
Cause
The external number range is relevant for accounts. The issue might be caused by the fact that some of the records are related to contacts, and IDs of contacts are always pulled from the internal number range. This range is exhausted.
Resolution
- Go to Business Configuration
- Go to Overview
- Search and open the activity General Business Partners.
- Select Define Number Ranges for Business Partners.
- Maintain the Internal number range to be sufficiently large, but without intersecting with the other ranges
See Also
Error While Creating Business Partner: "Number Range Depleted"
Keywords
migrate, Customer, Customers, account, import, migration , KBA , SRD-MD-BP , Business Partner , How To