Symptom
You have a picklist set under Picklist Center and you are unable to retrieve an specific label of this picklist via OData API.
Environment
SAP SuccessFactors HXM Suite
Reproducing the Issue
- Create a picklist under Picklist Center;
- Fetch the picklist values via OData API calls like the below:
- https://xxx.xxx.xxx/odata/v2/PickListValueV2?$filter=PickListV2_id eq 'xxx'
- https://xxx.xxx.xxx/odata/v2/PickListV2?$expand=values
- Some specific label is missing in the response;
Cause
There are different possible causes:
- Language Pack Feature is not enabled in Provisioning or not synchronized;
- Label is not set in Picklist Center or not synchronized;
Resolution
There are different resolutions for each cause:
- Go to Provisioning > Company Settings > Language Pack Feature and enable the affected label language.
If it's already enabled, to synchronize it, disable the language, save and enable it again in Provisioning. Note this should have no impact. - Go to Picklist Center > Select the Picklist > Click on the affected value > Click on the globe icon and set the affected label language.
If it's already set, to synchronize it, delete the affected picklist value following this chapter and create a new one equal the original.
Keywords
locale, picklist, language, pack, default locale, ja_JP, cn_JP, missing, miss, missed, label, labels, not, able, unable, retrieve, retrieving, fetch, fetching , KBA , LOD-SF-INT-API , API & Adhoc API Framework , Problem
Product
SAP SuccessFactors HXM Suite 2205