SAP Knowledge Base Article - Public

3212473 - Error 'There are still working times not yet submitted or awaiting approval' when closing a Customer/Enterprise Project

Symptom

When trying to close a Customer/Enterprise Project, the error 'There are still working times not yet submitted or awaiting approval' is being raised.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  • Close a Customer Project using app Plan Customer Projects;
    OR
  • Close an Enterprise project using app Project Control - Enterprise Project.

Cause

There are still pending timesheets for the relevant project.

Resolution

At first, it is necessary to look for the pending time entries associated to the affected project/WBS Element.

CDS view I_TimeSheetRecord can be used to find the time entries with status different than 'Approved' which link with the WBS Element.

After identifying the entries, it is necessary to understand if these timesheet entries are still required.

In case not, it is recommended to use API API_MANAGE_WORKFORCE_TIMESHEET in order to delete the entries, and therefore be able to close the affected project (s).

See Also

In order to use CDS View I_TimeSheetRecord, the Internal ID of the WBS Element is required. Information on how to extract such information can be found in the following KBA:

Keywords

S/4HANA Cloud, timesheet, time, entries, open, in process, cancelled, project, customer, close, error, pending, Plan Customer Projects, Project Control, Enterprise Project, WBS Element, there are still working times not yet submitted or awaiting approval, i_timesheetrecord , KBA , CA-TS-S4 , Cross Application Timesheet in S/4HANA , CA-CPD-SS , S/4HANA Public Cloud – Professional Service Projects , PPM-SCL-STR-FIO , Fiori UI for Project Structure (Public Cloud) , How To

Product

SAP S/4HANA Cloud Public Edition all versions