Symptom
You are searching with ID number in the Server Side Outlook add-in, however, no results are found despite it existing in Cloud for Customer system.
Environment
SAP Cloud for Customer
Server Side Outlook Integration
Reproducing the Issue
- Open the side panel in Outlook add-in
- Select the filter for example Opportunities
- Add the ID number from the Opportunity
- Search
- Result = there are no results
- Now search using the Name of the Opportunity
- Result = Entry is found
Cause
- Open Cloud for Customer system.
- Navigate to the path: E-mail Integration workcenter > Groupware Settings view > Profiles.
- Select the profile in use.
- Select ‘Add-in Settings' tab.
- Select the ‘Settings’ tab for the object card in question for example Opportunity.
- Here you can see that the field Search By is set to 'Name'.
Resolution
- Place the cursor on the last line of the ‘Search By’ box to see the available fields to search with.
- Here you can add the option for example 'ID' in the 'Search By' field.
Now searching in Outlook add-in in will return results when searching by Name and ID.
Keywords
server side outlook add-in , search not working , search no results , search ID , search name , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , Problem
Product
SAP Cloud for Customer core applications all versions