SAP Knowledge Base Article - Public

3212599 - Searching by ID in Server Side Outlook returns no results

Symptom

You are searching with ID number in the Server Side Outlook add-in, however, no results are found despite it existing in Cloud for Customer system.

Environment

SAP Cloud for Customer

Server Side Outlook Integration

Reproducing the Issue

  1. Open the side panel in Outlook add-in
  2. Select the filter for example Opportunities
  3. Add the ID number from the Opportunity
  4. Search
  5. Result = there are no results
  6. Now search using the Name of the Opportunity
  7. Result = Entry is found

Cause

  1. Open Cloud for Customer system.
  2. Navigate to the path: E-mail Integration workcenter > Groupware Settings view > Profiles.
  3. Select the profile in use.
  4. Select ‘Add-in Settings' tab.
  5. Select the ‘Settings’ tab for the object card in question for example Opportunity.
  6. Here you can see that the field Search By is set to 'Name'.

 

Resolution

  1. Place the cursor on the last line of the ‘Search By’ box to see the available fields to search with.
  2. Here you can add the option for example 'ID' in the 'Search By' field.

Now searching in Outlook add-in in will return results when searching by Name and ID.

Keywords

server side outlook add-in , search not working , search no results , search ID , search name , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , Problem

Product

SAP Cloud for Customer core applications all versions