Symptom
Custom Field is not available in Maintain E-mail Templates app for e-mail template extensibility.
You're using a Custom Field with business context Sales: Sales Document Item.
Environment
S/4HANA Cloud
Cause
For Custom Email Templates extensibility of sales documents, the custom field created must be for the business context Sales: Sales Document.
Resolution
Whenever you create a custom field, the field usage is enabled automatically for all your email templates. You can check this opening the custom field and checking the tab Email Templates.
The field with the business context Sales: Sales Document Item doesn't have any data in the "email templates" tab. However, when you create a field with the business context Sales: Sales Document, this tab will be populated automatically.
To be able to extend your e-mail template, please create a new custom field with the business context Sales: Sales Document.
Note: The Maintain Email Templates app displays only the first 100 available fields for your template. Therefore, you have to know the technical name of your custom field. You can see the first part of the technical name of your custom field in the Identifier column in the list of custom fields in the Custom Fields app. Add the suffix _SDH so that it follows the following format: YY1_<Name of your custom field>_SDH.
See Also
For more information, please check SAP Help Portal - Extensibility for Output Forms and Email Templates of Sales Documents
Keywords
output forms, email templates, sales documents, custom field, maintain e-mail templates, template extensibility, business context, sales document item, sales document , KBA , BC-SRV-COM-OM , Output Management: Email Templates , SD-SLS , Sales , Problem