Symptom
When trying to navigate to a custom section/ facet or a custom guided activity floor plan with a regular business user, you get an error. There is no issue for your development users.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Login with a regular business user
- Navigate to the relevant system area where the custom development is situated in the UI
- Error: ""UI application /YABC123_MAIN/SRC/BO/CustomScreens/Description/Screen/*.GAF.uicomponent is not in scope"." (YABC123_etc. represents the patch which would be referencing your PDI development solution name and path in the system).
Cause
The error is most likely caused by missing Access Rights policies.
It is not required for a PDI User, however, for a standard Business User, access rights/ policies have to be assigned.
Resolution
Update the user's access restrictions to include this new floor plan.
This can be done via business user access rights or via business role access rights.
You have to assign the GAF (Guided Activity Floorplan) or the relevant PDI view to a WorkCenter View and assign that corresponding WoCV to the business users directly, or to the relevant business role. This will ensure that the access rights policies are correctly generated for the user.
Deploy the Business Configuration upon assigning the GAF to a WoCV, this will ensure that the access rights are re-generated.
Check with your administrator should help be needed in updating the business roles.
Administration work centre >
- a) General Settings view > Business roles > Edit Access Rights > add the relevant access > update all users
- b) Business users view > select the relevant business user > Edit Access rights > add the relevant access > update
A system reload is needed for the users (log out and back in).
Keywords
KBA , LOD-CRM-ACC , Account , How To