Symptom
When you try to update the KUT field from GS/ISE, system is throwing error message "REST error from opportunity OData service: 400 bad request".
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP Cloud for customer
Reproducing the Issue
- Go to Sales workcenter
- Go to Guided Selling view
- Open any opportunity
- Update the extension field
Getting the error message: "REST error from opportunity OData service: 400 bad request".
Cause
The extension field is not added in C4C opportunity ODATA.
Resolution
Any updates from CNS to C4C (e.g. update of fields in guided selling / ISE) happens via a synchronous OData call to C4C opportunity.
This means that all fields in GS/ISE should be there in C4C opportunity ODATA. For standard fields this is handled by SAP. However for custom fields, customer has to make an additional configuration update via adaptation mode. Field need to be enabled in Odata for opportunity.
If this is not done, if try to update the extension field from GS/ISE, System will throw an error like mentioned in the steps to reproduce.
To add field in the C4C opportunity OData, please follow the below steps:
- Select the extension field in the Adaptation
- Click on Edit in the adaptation
- Go to OData Services tab
- Enable the field for Opportunity by checking the checkbox Field Added.
- Save
Keywords
REST error from opportunity OData service: 400 bad request , KBA , rest error from opportunity odata servic , LOD-CRM-SBS-GS , Guided Selling and Playbook , LOD-CRM-OPP , Opportunity Management , Problem