SAP Knowledge Base Article - Public

3213937 - When searching for an Account in the Agent Desktop, no contact is displayed in the results

Symptom

  • You are using the Agent Desktop add-on in C4C
  • After a searched for an account is returned, and if there is no contact selected, the AD would not automatically open the Customer Hub

Environment

  • SAP Cloud for Customer
  • SAP Cloud for Service
  • SAP Cloud for Sales

Reproducing the Issue

  1. Go to Services -> Agent Desktop
  2. Search for an account, and confirm it

Cause

System is working as designed

Resolution

  • The Customer Hub is used for Real-Time interactions
  • Only after confirming a contact related to the account, the Customer Hub view will automatically open
  • If the account does not have a contact assigned, then the user would need to manually click the "Customer Hub" tab to open it
  • When using the CTI/Telephony widget:
    • Upon accepting an incoming call or chat request, customer hub opens automatically, if the interaction is from a known Individual customer or contact
    • The customer hub loads the relevant customer or contact information
  • The solution captures details of the interaction in the timeline

Keywords

Agent Desktop, customer hub , KBA , LOD-CRM-LA , Live Activity , Problem

Product

SAP Cloud for Customer core applications 2205