SAP Knowledge Base Article - Public

3214326 - Unable to Manage Library Access

Symptom

You are trying to manage the access of a Library folder. However, no Sales Data, Employees, Accounts or Territories are available to be add on the access list.

Environment

 SAP Cloud for Customer

Reproducing the Issue

  1.  Library workcenter > Attachments view; 
  2. Select folder ABC (ABC represents the folder ID);
  3. Click "More > Manage Access";
  4. See that, in all tabs, Sales Data, Employees, Accounts and Territories, the "Add" button is grayed out and you are unable to change the accesses to this folder.

Cause

This is system expected behavior.

Resolution

Only the owner of the folder can manage the access to the folders on Library workcenter.

As the owner of a document or folder, you can define whether the document or folder is public or private. Access to a private document or folder can be restricted to specific sales data, accounts, employees, and territories.

In addition, you can authorize other employees to administer the document or folder by checking their Grant User Access fields.

Items that have access to a parent folder can access all the child folders and documents within the folder. Items with such Inherited Access cannot be edited or deleted.

Also, please note that you cannot change the administration right for an employee with inherited access. In a case like this, you must add the employee explicitly for editing.

Inherited access can also be granted due to access control that has been configured by your administrator.

See Also

Solution Guide for SAP Service Cloud - Library

Keywords

Library, Manage Access, Folder , KBA , LOD-CRM-BF-DLP , C4C: CRM Basic Function - Document Lookup , LOD-CRM-BF-ATT , Attachments , How To

Product

SAP Cloud for Customer core applications all versions