SAP Knowledge Base Article - Public

3214747 - Employee Profile data not visible in Adhoc report

Symptom

  • Data appearing on the Employee Profile background field is not visible when running a Table report for users with multiple employments.
  • If you delete the users entry, save and enter it again via UI the data appears on the report.
  • The option ""Enable Person Based Background Information Blocks" is selected in Company System and Logo Settings.

Environment

  • SAP SuccessFactor HXM Suite
  • SAP SuccessFactors Employee Profile

Reproducing the Issue

  1. Go to employee profile of the affected user;
  2. See that the information on the background block appears as expected;
  3. Run a Adhoc (table) report with the background block information;
  4. Check that the data does not show. Field appears blank.

Cause

This is expected behavior.

Adhoc reports do not support person-based entries.

Resolution

The option "Enable Person Based Background Information Blocks" does not apply to the Adhoc Reports. It only enables the user to see the information on the Employee Profile.

With this option enabled, if a user that has multiple employments has one entry in one of the employment's background block, it will show the same entry/data in all other users's background blocks on the Employee Profile.

If the data on the background block is present on the past employment, when generating the report, the data will only be present on the past employment and not on the new/current one, even if it shows on the Employee Profile.

Keywords

employee profile, report, background information, background block, adhoc report, data missing on report, report not showing background info , KBA , LOD-SF-EP-REP , Ad Hoc Report (Employee Profile) , Problem

Product

SAP SuccessFactors HXM Suite Core 2205