Symptom
An error is displayed when trying to add new records and/or updating/deleting existing records (including via imports and API) for Russian employees.
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
This error may occur in several different scenarios, via different tools, with different transactions and objects/entities, but a sample one is:
- Go to employee's Job Information;
- Open Job History;
- Try to delete Termination record;
- Save and get an application error.
Cause
This error only happens when Russian DRS is enabled and the employee that is trying to make the changes does not have permission to "PersonDataResidencyLogRecord".
Further details on implementing and managing Russia Data Residency Solution can be found in the Implementation Handbook.
Resolution
Grant employee "Miscellaneous Permissions" > "PersonDataResidencyLogRecord" permission in Manage Permission Roles.
Support Engineers please review internal memo.
See Also
- 2601430 - Russian Data Residency
- Assigning Role-based Permission to Person Data Residency Log Record
Keywords
ECT-172907, The system has encountered an unknown error on import. Please contact the System Administrator, Unknown Error, System error. Please contact administrator, An application error occurred. Please try again later, or notify support, Error on Deleting Information, Error Deleting Termination, Error on Import, Job Information, Termination Details, API, Import, UI, Update, Add, Delete, Insert, New Record, Upload, RBP, RDP, Russian Data Privacy, Permission, Error while persisting PII data, DRS EntityUUID list for soft delete is Empty!!, DRS, Russia, Russian , KBA , LOD-SF-EC-RBP , Roles & Permissions (EC Core only) , LOD-SF-EC-JOB , Job Information , LOD-SF-EC-CMP , Compensation Information & One-Time Bonus , LOD-SF-EC-EDP , Import Employee Data (EC Core only) , Problem