Symptom
If the C4C Opportunity has inconsistent data (e.g. when an inactive business partner is used), the Opportunity is not replicated to external systems.
Environment
Cloud for Customer
Reproducing the Issue
- Open the Opportunity ID;
- Make a dummy change in the OPP, e.g. change the Closed Date.There is No Outbound Message triggered to external system;
Cause
Opportunities while in Inconsistency status, are not transferred to avoid several side effects in the master data of target system. The same applies to all customers or C4C systems.
Resolution
In order to make use of this feature, please create a new Communication Arrangement Filter of Send inconsistent Opportunities for Opportunity Replication to SAP Business Suite:
- Go to Administrator and General Settings
- Click on Communication Arrangement Filters
- Create the new filter as per inputs above.
See Also
Keywords
Opportunity;outbound;inconsistency; replication; Extract to External System , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Known Error