SAP Knowledge Base Article - Public

3215258 - Replicate Inconsistent Opportunities

Symptom

If the C4C Opportunity has inconsistent data (e.g. when an inactive business partner is used), the Opportunity is not replicated to external systems.

Environment

Cloud for Customer

Reproducing the Issue

  1. Open the Opportunity ID;
  2. Make a dummy change in the OPP, e.g. change the Closed Date.There is No Outbound Message triggered to external system;

Cause

Opportunities while in Inconsistency status, are not transferred to avoid several side effects in the master data of target system. The same applies to all customers or C4C systems.

Resolution

In order to make use of this feature, please create a new Communication Arrangement Filter of Send inconsistent Opportunities for Opportunity Replication to SAP Business Suite:

  1. Go to Administrator and General Settings
  2. Click on Communication Arrangement Filters
  3. Create the new filter as per inputs above.

See Also

2630993 - Updates of Opportunities Whose Assigned Account is Inactive are not Replicated to the Target Backend System

Keywords

Opportunity;outbound;inconsistency; replication; Extract to External System , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Known Error

Product

SAP Cloud for Customer core applications 2008