Symptom
Account duplicate check behaviour differs depending on scoping of country dialling code.
Environment
SAP Cloud for Customer
Reproducing the Issue
Duplicate Check behaviour changes depending on scoping
Follow the path: Business Configuration Scoping work centre > Implementation projects view > select the relevant project > navigate to step 4., Question > Expand: Built-in Services and Support -> Business Environment -> Addresses and Languages -> Phone Number Country Defaulting:
"Do you want to suppress the defaulting of the country dialing code for phone numbers without country dialing code?"
Go to the Customers work centre > Accounts view > create new.
- with scoping ON (select this scoping question and finish the scoping, reload the system)
Result: ---> duplicate check shows potential duplicates if last few digits of telephone number match with some other account.
- with scoping OFF (DE-select this scoping question and finish the scoping, reload the system)
Result: ---> system checks complete 10 digits of a phone number and displays the result in the duplicate check.
Cause
a. The weights are relative. It is regular misunderstanding that a phone weight of 100 means that only the phone number is regarded during the Duplicate Check, or that the phone number has to be 100% identical. This is wrong. Please see the blog "Algorithm behind duplicate check rule" (link below in the 'see also' section) with detailed information how the algorithm and the weights work.
b. The Duplicate Check performs a fuzzy search that means that it is not necessary that an account’s phone number has to be 100% identical to be displayed as a potential duplicate.
With standard settings a similarity of at least 80% is sufficient
If your Duplicate Check weights look like this:
Phone = 100
E-Mail = 100
All other weights are 0.
This means that only Phone and E-Mail is regarded during the Duplicate Check.
Other attributes like Name or Postal Address fields are completely ignored.
Phone and E-Mail have the same influence on the similarity. There would be the same behaviour with this setting:
Phone = 1
E-Mail = 1
All other weights are 0.
We recommend to restore the Default Values to get more realistic results. Especially the Name weight should not be set to 0.
Resolution
It is a correct and wanted behavior that the Business Partner Duplicate Check shows potential duplicates even though the phone weight is set to 100 and the phone numbers are not 100% identical.
The scoping does not really change the Duplicate Check behavior. It just leads to two different Duplicate Check search cases.
Imagine you create a new Account, enter the data below and click ‘Check for Duplicates’:
Name = SAP SE
Country = DE
Phone = 06227 123456
Case 1: With standard settings, i. e. phone number country defaulting ON
The Phone number is automatically changed to ‘+49 6227 123456’
The Duplicate Check searches with
Name = SAP SE
Country = DE
Phone = +49 6227 123456
Case 2: With scoping question = ON, i. e. phone number country defaulting OFF
The Phone number keeps unchanged as 06227 123456
The Duplicate Check searches with
Name = SAP SE
Country = DE
Phone = 06227 123456
This means the Duplicate Check searches with different Phone numbers and therefore you get different similarities which might lead to the fact that certain Accounts are displayed as potential duplicates in one case and not in the other case.
See Also
- KBA 2340526 - Duplicate Check
- Blog: Algorithm behind duplicate check rule
Keywords
KBA , LOD-CRM-ACC , Account , Problem