Symptom
- You are using the CTI Local Adapter scenario with your CTI integration per KBA 3156554
- When a call arrives, the inbound notification creates many additional browser popup sessions with the OK response
- Business would like to avoid such situations, which causes irritations to the users and impacts their performance
- How can this popup be suppressed?
Environment
- SAP Cloud for Customer
- SAP Cloud for Service
- SAP Cloud for Sales
Reproducing the Issue
- Make several inbound calls
- With each call a new browser window is popped up (with the message "OK"), which causes the users to constantly closing unused sessions
Cause
- 3rd party issue
- The "All OK" message is the HTTP response returned by the CTI adapter to advise that the request has been successfully completed.
- When CTI passes the information using the browser, such be side effects will be observed
Resolution
- Request the CTI provider to avoid sending the URL parametrized commands via the browser
- Instead of using the browser to pass the payload information to the CTI Local Adapter, have the CTI send the same information in the background
- See the example provided using C#:
urlparam1 = “ANI=408-361-3611&DNIS=1-800-455-5555&BP=1000655&SerialNo=XY234567T&TicketID=8003456&Type=CALL&EventType=INBOUND”; urlparam2 = urlparam1 + ExternalReferenceID=56432156787890&Custom_1=value1&Custom_2=value2&Custom_3=valu31&Custom_4=value4”; “url = http://localhost:36729/?CID=BCM1234&” + urlparam2; HttpWebRequest webReq = (HttpWebRequest)WebRequest.Create(url); HttpWebResponse WebResp = (HttpWebRequest)webReq.GetResponse();
In this example, Urlparam is split into multiple strings only for better readability.
See Also
3156554 - CTI Integration Options with SAP Cloud for Customer (Service and Sales)
Keywords
Suppressed, URL, CTI Local Adapter, Multiple pop-up windows, http://localhost:36729/?CID=BCM1234&ANI, CTI; All OK; HTTP; Response; landing page opens , KBA , LOD-CRM-LA , Live Activity , Problem
Product
SAP Cloud for Customer core applications 2205