Symptom
You have created a Sales Order and when navigating to the Items tab, you noticed that the delivery groups are different between the items, despite having the same Delivery Rule.
Environment
SAP Business ByDesign
Reproducing the Issue
In this example, we will be creating a Sales Order via the UI (User Interface), however the behavior also applies for Orders created via Webservice.
- Go to Sales Order workcenter.
- Go to Sales Orders view.
- Select All Orders then search for ABC (ABC represents the ID of the Sales Order created).
- Click Edit then View All.
- Go to Items subtab.
- Item 10 has the Delivery Group: 3
- Item 20 has the Delivery Group: 4
Cause
The Ship-To address has been specified at item level (individual items) and in such cases the system will generate a different GUID (globally unique identifier) for each item even if the addresses are the same.
Resolution
This is the system expected behavior.
If all the items in the Sales Order are going to the same Ship-To address, the address should be maintained on header level so that the same cascades to the items.
or
If there is a difference in Ship-To address between the items, please maintain the Ship-To addresses in the Account master data.
For webservice scenarios, when there is a difference in Ship-To address between the items, please maintain the Ship-To addresses in the Account master data and then use the relevant address reference GUIDs at item level in the payload.
See Also
2709773 - Complete Delivery Order With Multiple Deliveries
Keywords
Sales Order, Webservice, Payload, Delivery Group, Delivery Rule, Item, Difference , KBA , AP-SLO-SO , Sales Order , How To