SAP Knowledge Base Article - Public

3217601 - Custom picklist field does not sync to EP - Employee Central

Symptom

When adding a new field to a standard picklist, the field is visible in EC, but it is not correctly synchronized to EP. The standard picklist values are correctly synchronized, but the custom are not.

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Configure a new value in a standard picklist that is associated to an EC field;
  2. Edit an employee's information and add this new picklist value;
  3. Save the information and check if it was propagated to EP (after HRIS Sync);
  4. New value is not shown;
  5. Edit the employee's information and add a standard value;
  6. Check the EP field; value is now shown.

Cause

This synchronization issue happens because the field does not have a translation in the company locale. The system is configured in another language and the option to add the translation in the picklist field is not available.

For example: company locale is English US, but the default locale in Provisioning is English UK and there's no option to add the translation to English US in the picklist value.

Resolution

Please your partner to enable the correct language in Provisioning (according to the company locale) and add the label for the new language in the picklist values.

See Also

3170609 - Picklist values are not searchable when translation is not maintained for the enabled language

Keywords

picklist, sync, synchronization, EP field blank, empty EP field, picklist sync, default locale, label translation  , KBA , LOD-SF-EC-HRS , HRIS Sync , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions