Symptom
Error message "Deleting item is not possible, because follow-up document exists." is thrown when trying to delete an Item in a Sales Order.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Sales Workcenter.
- Navigate Sales Orders view.
- Open a Sales Order which contains an Item you want to delete.
- Go to Products facet.
- Select the mentioned Item.
- Try to delete it.
- Error message appears.
Cause
This is the current system behavior of SAP Cloud for Customer. Unfortunately, it is not possible to delete the Item if there is a follow-up document (e. g. Ticket).
Resolution
As a workaround, one possibility is to delete the Item in the follow-up document which correspond to the Item to be deleted in Sales Order. With that the reference in the Sales Order, item will be removed.
To avoid such issue, the best way is not to delete quote items but to cancel them because deletion of a quote item is not allowed once it has been partially processed, for example once it is already outputted.
Keywords
Delete, Remove, Product, Sales Order, Sales Quote , KBA , LOD-LE-CQP-CO , Lean Sales Orders , Problem