SAP Knowledge Base Article - Public

3217750 - Can't Activate OIM due to Ledger Balance Mismatch

Symptom

You wish to activate Open Item Management for a G/L Account but encounter the following errors:

  • Error Message no. FAGL_SWITCH_OP105 "Balance of ledger & differs from balance of line items of the account“
  • Error Message no. FAGL_SWITCH_OP053 "Account balance in currency &&& differs from ledger balance“
  • Information: Company code &&: Ledger &, balance xxx (line items) xxx (from ACDOCA)

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP S/4HANA Cloud

Reproducing the Issue

  1. Open 'Schedule Accounting Data Corrections' (App ID F4622)
  2. Select 'Create'
  3. Choose job template 'Activate Open Item Management for G/L Accounts'

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  4. Select 'Start Immediately'

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  5. Enter desired values 

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  6. Select 'Schedule'
  7. View log and see errors

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Cause

The system performs the switch to open item management on your Start date. For the items posted in the future will cause balances in the account and in the ledgers - are NOT identical.

If there are items posted in the future exist, above errors can be caused.

Resolution

This is a limitation of our activation tool. So the activation can only work if you make sure that the items in the future are reversed or offset or just wait for the future posting date to do it.

See Also

Activate Open Item Management for G/L Accounts

KBA3017976 - Ledger balance mismatch in OIM activation

Keywords

OIM, open item management, ledger, error, balance, ledger balance, currency, ACDOCA, line items, differs, failed, not working, activate, deactivate, FAGL_SWITCH_OP116 FAGL_SWITCH_OP105, FAGL_SWITCH_OP, FAGL_SWITCH_OP106,  FAGL_SWITCH_OP115, Switch Date , KBA , FI-GL-GL-X , Database Inconsistencies , FI-GL-GL-X-2CL , Database Inconsistencies (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions