SAP Knowledge Base Article - Public

3218100 - Cancelled onboarding and reinitiate in Recruiting, candidate does not appear in Onboarding dashboard - Onboarding

Symptom

  • Cancelled onboarding and reinitiate in Recruiting, candidate does not appear in onboarding dashboard
  • Onboarding2Workflow entered error

Environment

SAP SuccessFactors Onboarding

Cause

In Manage Process Tasks could see candidate entered error with following:

Exception encountered while authorizing user for activity: Activity [Activity{type=SERVICE, name=;com.successfactors.hris.service.dataretentionmgmt.ExecuteECDataPurgeByUserSysId&;, context=null}].

Resolution

  1. In Provisioning Enable Data Retention Management was not checked/enabled
  2. Enabled this feature in provisioning
  3. Then restarted the failed task in Manage Process Tasks Page
  4. Candidate entered Dashboard

Keywords

reinitiate, candidate disappear, ExecuteECDataPurgeByUserSysId, dataretentionmgmt, onboarding2workflow error , KBA , LOD-SF-OBX-BPE , BPE Process Flow , Problem

Product

SAP SuccessFactors Onboarding 2205