Symptom
In Display Changes of Business Role or Business User:
- There's an action with the following message: "Authorizations have been reorganized/optimized due to technical reasons"
- There are Business Users/Business Roles edited by SAP_LMADM.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
Access Display Changes screen in Business Role or Business User.
Cause
The user SAP_LMADM is a SAP Technical User, a Technical User is predefined by SAP to run operating tasks in the SAP S/4HANA Cloud Public Edition system. SAP technical users are also required for customer-specific tasks, such as running and scheduling jobs. In other words, they're services that are used to automate technical tasks in the system, for example, a print queue user who pulls print jobs remotely.
The message "Authorizations have been reorganized/optimized due to technical reasons" means that during a tasklist run the authorizations have been regenerated. This can happen e.g. if a hotfix is deployed that contains changes in a Business Role and Business Users that have these roles/catalogs assigned will get updated because the roles will be regenerated.
Resolution
SAP_LMADM is a technical user used to adjust and modify backend objects related to business users. For example, a business catalog gets deprecated/deleted within a business role or an application gets deleted/moved to a different catalog. Also, every system upgrade business users get adjusted based on SAP changes on business catalogs.
A technical user does not perform business role assignments, only backend technical objects change.
In the Blog Post Identity and Access Management Authorization Assignment there's a note where it says: "Entries with “Authorizations have been reorganized/optimized due to technical reasons” can be ignored as these indicate SAP system internal reorganizations and do not necessarily indicate authorization changes."
Therefore, these "changes" doesn't indicate a potential issue in system as they are not actually effective changes.
See Also
SAP Help Portal | Display Technical Users
SAP Blog Post | Identity and Access Management / Authorization Assignment (Part 3.2)
Keywords
technical user, SAP_LMADM, operating tasks, business users, business roles, business catalog, SAP Lifecycle Management Administrator , KBA , BC-SRV-APS-IAM , Identity and Access Management , Problem