Symptom
In a scenario where you wish to display Sales Quote IDs and Preceding Opportunity IDs in the Sales Quote Item Data Source, some data is shown as '#' instead of the expected value.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Business Analytics work center.
- Open the Design Reports view.
- Search for Data Source 'Sales Quote Item'.
- Highlight it and click on Preview
- Under Selection, filter by Sales Quote IDs ABC, DEF and GHI (Where ABC, DEF and GHI represent IDs of multiple Sales Quotes).
- Under View, remove the fields from the Columns and add fields 'Sales Quote' and 'Preceding Opportunity'.
- Run the Report.
You see that some of the IDs are displayed correctly, but others are displayed as '#' (For both Sales Quote IDs and Preceding Opportunity IDs).
The same is also true if filtering by Preceding Opportunity ID instead of Sales Quote ID.
Cause
This is how the system checks the IDs in this Data Source:
- First, the system takes the Sales Quote Items and checks for Opportunities which are linked to that item.
- Then, the system checks if the Sales Quote itself is consistent.
- If the items have no reference to the Opportunity, the Data Source will show the ID as '#'.
So, we have 3 cases where the ID will be shown as '#':
- If the Sales Quotes have no items that reference an Opportunity (For example: If the items in the Sales Quote have been added manually, instead of being carried over from an Opportunity).
- If the Sales Quote has no items.
- If the Sales Quote is inconsistent.
This happens because the Data Source is based on the Sales Quote Items, and not the Sales Quote itself.
Resolution
This is the expected system behaviour.
Keywords
Sales Quote, Item, Preceding, Data Source, CRMCQTIB, Opportunity, Inconsistent, Not Showing, Not available, Pound, Hashtag , KBA , SRD-CRM-QUO , Quotations , How To