SAP Knowledge Base Article - Public

3220419 - Address Information not sent from Employee Central to C4C

Symptom

The home address is not flowing to C4C, even if it's maintained in SuccessFactors Employee Central.

Environment

  • SAP Hybris Cloud for Customer Add-ins

Reproducing the Issue

In Employee Central,

  1. Check for Business Address maintained in the Location Object
  2. Assign this Location to the Employee 
  3. Replicate the employee to C4C.

In C4C,

  1. Go to the Administrator work center and select Web Service Message Monitoring .
  2. In EmployeeCentralEmployeeReplicationIn Interface, observe that <AddressTypeCode> Business is missing.
  3. In Interface  EmployeeReplicationIn, observe that all other <AddressTypeCode> parts of EmployeeCentralEmployeeReplicationIn is ignored.

Result: An employee created in C4C is missing address information.

Cause

  • The Business Address tagged to Location data of the Employee in Employee Central is not flowing to CPI and C4C.

  • Due to data privacy regulations in C4C , We only replicate Address, Phone, Mobile and Email Information from Employee Central to C4C only if it’s of type ‘Business’/’business’, ‘B’, ‘CELL’ and ‘B’ respectively.

For Example ,The <AddressTypeCode>home</AddressTypeCode> in EmployeeCentralEmployeeReplicationIn is classified as personal information and should not be stored in C4C.

Resolution

  • In C4C due to data privacy regulations system consider only address type "business" or "Business", all other AddressTypeCode will be ignored by EmployeeReplicationIn when saving the data in C4C.

 

See Also

Keywords

Employee replication, Address , Business , Location , EmployeeCentralEmployeeReplicationIn , EmployeeReplicationIn , SF ,C4C . , KBA , LOD-CRM-INT-EC , Integration of C4C with Employee Central , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 2205 ; SAP Cloud for Customer core applications all versions