Symptom
When entering a search term using the search functionality in Sales WEBGUI apps, the search result does not match exactly.
"Image/data in this document is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
S/4HANA Cloud Public Edition
Reproducing the Issue
As for example:
1. In the "Order" field of the "Display Sales Orders - VA03" app, search for a single term;
2. On the "Search Results" screen, the system does not get an exact match on the search, but is showing as well others values:
Cause
Fuzzy search feature is enabled in the search help of sales apps.
Resolution
This is the expected behavior of the fuzzy search feature. With fuzzy search it is possible to search for structured database content that is similar to the user input. "Similar" in this case means that the user input and the records in the database are "nearly" the same, but differ in their spelling (e.g. typing errors) or contain additional information (e.g. additional or missing terms).
Below are steps to disable the fuzzy search function:
Note: After turning off the fuzzy search function, it means no drop-down list will appear when entering characters in the search field. It is needed to use F4 to search.
- Go to Display Sales Orders app
- Go to More -> GUI Actions and Settings -> Settings
3. Click Save
See Also
Details can be found here: FUZZY Search | SAP Help Portal
Keywords
Search results, VA03, Sales order, Display Sales Documents, Display Sales Orders, Search result, Fuzzy search, V4, Search help, F4, Term, Functionality , KBA , SD-SLS-SO , Sales Orders , SD-SLS , Sales , SD-SLS-SO-2CL , Sales Orders (Public Cloud) , How To
Product
Attachments
Pasted image.png |
Pasted image.png |
Pasted image.png |
571616bc97582ad8a98170400153af22 |
9f16d2bc97582ad8a98170400153afe6 |
df16d2bc97582ad8a98170400153affe |