SAP Knowledge Base Article - Public

3220736 - Search query is not working(no data) when create a model based on a BW or S4HANA live connection

Symptom

When search query by any keyword when create a model based on a BW or S4HANA live connection, no data is shown.

Environment

SAP Analytics Cloud

Reproducing the Issue

  1. Create a live mode in SAC.
  2. Select System Type: SAP BW.
  3. Select a BW or S4HANA live connection.
  4. Click the value help for Data Source.
  5. Input any value and click "Search" icon, no data.
  6. Run RSOSN_SEARCH in SE38 and search by the same keyword, below error occurred:
    Unable to fetch result
    Error in program CL_RSOS_UTILITIES=============CP (Include CL_RSOS_UTILITIES=============CM005, source position 25)
    A database error occured. The error message in the  database was: "invalidated view: system-local.bw. bwsearch.SAPSR3.AINX.METADATA::PRIMARY"
    Error in program CL_SQL_STATEMENT==============CP (Include CL_SQL_STATEMENT==============CM00L, source position 3)

Cause

The error is caused by invalid search views.

Resolution

To resolve this issue, re-create the BW search views. This can be done for all views or for a single TLOGO object. Please refer to the solution in KBA 2494986.

In case the same situation happens for multiple TLOGO types, please switch off the BWSEARCH in RSOSM and then re-enable it, so the system can regenerate all required views and HANA objects.

See Also

KBA 2494986 Invalidated view: system-local.SAPERP.xxx.METADAT A::PRIMARY

Keywords

No values, Empty result, No result , KBA , LOD-ANA-LDC-BW , SAC Live Data Connection BW , BW-WHM-MTD-SRCH , BI Search , Problem

Product

SAP Analytics Cloud 1.0