Symptom
A Custom Form Template of Customer Invoice was set up, but the form is not picked correctly while previewing Customer Invoice.
Environment
SAP Business ByDesign
Reproducing the Issue
- Navigate to Application and User Management work center.
- Go to Form Template Maintenance view.
- Search for Form Template "Customer Invoice (Japanese)" and open it.
- You will see the form is picking a Standard Form.
Or
- Navigate to Customer Invoice work center.
- Open Invoice-XXXX and Preview it.
- You will see the Invoice is displayed in Standard Form.
Cause
The appropriate template variant is picked up by output management based on Country Code and Language Code.
Method to check Language Code:
- Navigate to Customer Invoicing work center.
- Find the relevant Account in Customer Invoice and open it.
- View All.
- Go to General Tab.
- You will find Language Code under Main Communication Tab.
If the Language Code is not maintained, default language is picked, which is English and hence corresponding template is picked.
Resolution
- Navigate to Customer Invoicing work center.
- Find the relevant Account in Customer Invoice and open it.
- View All.
- Go to General Tab.
- Maintain Language Code under Main Communication Tab.
See Also
For more information about how system picks form for customer invoices, please refer to KBA 2591499.
Keywords
Custom Form Template, Standard Form, Custom Invoice Form Template, Language Code , KBA , AP-RC-FF , Forms Flexibility , AP-RC-OUT , Output Management , Problem