Symptom
Employee is Unable to see the Type of Leave while creating the Leave Request
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Home work center
- Go to Self-Services Overview view
- Select New Leave Request
- Employee is unable to see the type of leave while creating leave request
Cause
As the Data is fetching from Time Type not from the Time Account Type while creating leave request by the employees because time type is only referring to which time type you are going to use for the requests and that actually mapped to the time account type. Please check below steps for the comparision
A) To Check Time Type
- Go to Business Configuration
- Open Overview view
- Search for Time Types
- Open the Activity
- Click on Maintain Employee Time Types
- Check the respective Time Type
B) To Check Time Account Type
- Go to Business Configuration
- Open Overview view
- Search for Time Accounts
- Open the Activity
- Click on Maintain Time Account Types
- Check the respective Time Account Type
- Compare both Time Type and Type Account Type
Resolution
Mapping or Associating the time type with the respective time account type can resolve the issue and employees can be able to see the respective time type while creating leave request.
Keywords
Time Types,Time Account Types,Leave Request,Mapping Time Type , KBA , SRD-HR-TLM , Time and Labour Management , Problem