Symptom
- Customer change username for user but the system and imported via Basic Import ,validation is successful but in monitor job the import fails
- Error: The following users were not imported or updated because the username already exists in the system. To check details of the duplicated user.
- Trying permanent purge give error: DUPLICATE_USERNAME : Failed to add/update user XXXXX
Environment
SAP SuccessFactors HXM Suite
Reproducing the Issue
- Import the user with username change
- Import fails with duplicate username
- check tool doesnot provide any data
- user not found in " table_user_sysinfo "
Cause
- the username is still existing in User account tables. (Table_USER_ACCOUNT)
- Go to Admin Center -> Manager Login Accounts page.
- Search Login Name with the username and edit the Login name to another one.
Resolution
- Please note that you can either change the LOGIN NAME field in "manage login accounts " page which owns the value and then you can import your user it shall work
OR - You can try purging the user with username as checked in Manage login accounts page because that is what is assigned to user due to some data inconsistency or stale data.
OR - a) change username of impacted users to login name in UDF and import in system with Basic import.
b) change those username back to the old username then re-import into system with basic import function
c) those step will release the login name from the TABLE_USER_ACCOUNT table
Once you apply one of the two ways you can import back you data.
Keywords
Table_USER_ACCOUNT, manage login accounts, purge, USERS_SYSINFO , KBA , LOD-SF-PLT-UIM , Employee Import Issues , Problem
Product
SAP SuccessFactors HXM Suite all versions