Symptom
While performing undo-release of Confirmed Inbound Delivery against a Third Party Processing document, the system throws the below errors:
Cannot save the document as inconsistent; document already released
Save failed
Quantity entered exceeds delivery qty for item A in Outbound Delivery XYZ ( i.e. here A refers to an Item ID and XYZ refers to an Outbound Delivery ID.)
Environment
SAP Business ByDesign
Reproducing the Issue
Step: 1
- Go to the Inbound Logistics work center.
- Go to Common Tasks and create New Customer Return Notification
- In guided activity, enter relevant Third Party Outbound Delivery ID.
- Navigate to Step 2, here maintain Delivery Notification ID, and Ship to location.
- Now under the Details subtab, keep follow-up activity as Return to the supplier only.
- Navigate to Step 3 and choose Finish.
- Once the guided activity is completed, Inbound Delivery Notification gets generated.
- Again go to the Inbound Logistics work center and find the newly generated Inbound Delivery Notification ID.
- Select it and perform Post Goods Receipt.
- At last, Confirmed Inbound Delivery ID: C is generated. (i.e. here C refers to Inbound Delivery ID)
Step 2:-
- Again go to New Customer Return Notification and create a new Inbound Delivery Notification of type: Customer Return.
- In this case, again enter the same Outbound Delivery ID as above i.e. XYZ with the same item.
- The system will throw an error thrown straight away.
- Now, enter Ship to location and change Follow-up activity to Post to own goods under the Details section.
- The system still throws the same error however Inbound Delivery Notification can still be created.
- Navigate to Step 3 and choose Finish.
- Once the guided activity is completed, Inbound Delivery Notification gets generated.
- Now go to the Inbound Logistics work center and find the newly generated Inbound Delivery Notification ID.
- Select it and perform Post Goods Receipt.
- Once the process is completed, another Confirmed Inbound Delivery ID: D is generated. (i.e. here C refers to Inbound Delivery ID)
Step 3:-
- Go to the Inbound Deliveries work center
- Go to Inbound Deliveries view.
- Here, search for the first Confirmed Inbound Delivery ID: C created via Step:1. (i.e. here C refers to Inbound Delivery ID)
- Select it and choose Undo-release.
- The system throws the above error messages.
Cause
Since two Confirmed Inbound Deliveries with (Delivery Type: Customer Return) were created with reference to one Third Party Outbound Delivery: XYZ therefore when a user tries to perform undo-release of the first Confirmed Inbound Delivery ID: C in random order system throws errors.
Resolution
-
Go to Inbound Deliveries work center
- Go to Inbound Deliveries view.
- Now, perform Undo-release for the second Confirmed Inbound Delivery ID: D which got generated as per Step:2
- Once it is done then cancel the same.
- Later perform Undo-release and Cancel the first Confirmed Inbound Delivery ID: C as well which got generated as per Step:1
See Also (optional) ⓘ
Keywords
Third Party Order Processing, Inbound Logistics, Customer Return, Undo-Release, Cannot save document as inconsistent; document already released, Quantity entered exceeds delivery qty for item in Outbound Delivery , KBA , third party order processing , cannot save document as inconsistent; d , quantity entered exceeds delivery qty fo , customer return , inbound logistics, , undo release , AP-IDP , Inbound Delivery Processing , How To