Symptom
- The Messaging activity is not displaying the "Customer" or "Mobile" number
- The "Customer" or "Mobile" number is blank
Image/Data is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP Cloud for Customer
- SAP Cloud for Sales
- SAP Cloud for Service
Reproducing the Issue
- Navigate to Service Work Center
- Navigate to Tickets Work Center view
- Open any ticket
- Navigate to Timeline tab
- Click SMS
- Select the "From" as for example "SAPNC4C" or what has been defined as a channel
- Manually enter a phone number/mobile number in the "To" field
- Add any text and click Send
- Go to -> Activities -> Messaging Open up the Messaging Activity
- Notice the same is not displaying the "Customer" or/and the "Mobile" number to which SMS was sent.
Cause
- If a party is determined for the recipient phone number, the same is displayed in the timeline view as well as in the Messaging Activity
- However, if there is no party UUID/name found, the recipient/customer field remains blank
Resolution
- Currently, in the SMS activity, by standard the system offers the "Customer" field to identify the recipient of the message
- Workaround:
- Please use List View instead of Time Line View
- Timeline only shows the "To" information for identified customers. It does not show the mobile number if un-identified.
- With the List View in the timeline, users can also see the recipient information, as seen in the below example screenshot
- Additionally:
- Instead of manually entering the phone number, use the F4/Help (popup) and search for the party
- Ensure the phone number to which the SMS is sent, has a corresponding BP maintained with such number
See Also
3223739 - Duplicate SMS Activities are created when a failed SMS attempt is followed by a successful attempt
Keywords
SMS, phone, to, cell, mobile, empty , KBA , LOD-CRM-SRP , Service Request Processing , LOD-CRM-SRP-INT , Ticket Interactions , Problem
Product
SAP Cloud for Customer core applications 2205