SAP Knowledge Base Article - Public

3222381 - Caller ID Functionality Not Create Inbound Call Activity at C4C Extended App

Symptom

You have enabled the Caller ID functionality for Cloud for Customer (C4C) mobile application (Extended App).

However, after receiving the call you notice that the application is not creating automatically an activity for inbound call.

Environment

  • SAP Cloud for Customer
  • Extended App (Mobile Application) 

Reproducing the Issue

  1. Receive a phone call in your iPhone.
  2. Caller is identified as a C4C contact.
  3. After the call nothing happens.

Cause

There is no feature where a phone call activity could be created from outside the C4C application.

The only way the application automatically prompts a user to create a phone call activity is when the user taps on the phone number within the C4C app places the call and comes back to the C4C app after the call ends.

Resolution

This is an expected system behavior.

An alternative option may be to check the SAP Cloud for Customer Customer Influence to submit an idea for a new feature:

See Also

SAP Help Page - C4C Extended App - Mobile Settings

Keywords

caller id, mobile app, iphone, inbound call, extended app , KBA , AP-RC-MOB-IPD , SAP Hybris Cloud for Customer Extended App on iOS , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 2205