SAP Knowledge Base Article - Public

3223277 - Employees Can See Manager Ratings and Comments After Routing a Performance Form Back A Step

Symptom

After a performance form is routed back a step, employees can see manager ratings and comments.

Environment

  • SAP SuccessFactors Performance Management
  • SAP SuccessFactors Calibration

Reproducing the Issue

  1. Employee completes their section in a performance form
  2. Form is routed to a manager step or calibration step
  3. The manager adds comments and ratings
  4. The form is routed back to the employee step
  5. Employee can see manager comments and ratings

Cause

There are no permissions restricting the employee's ability to see a manager's comments or ratings

Resolution

Option 1

  1. Route the form to the manager in a step where they have write access for section comments and ratings
  2. Have the manager remove the comments and ratings so the employee won't see them
  3. Route the form back to the employee

Option 2

  • Launch a new form and ensure it's only processed forward through the route map steps

Prevention

To prevent this moving forward, permissions can be adjusted in performance form templates to account for this situation. For calibration steps, it's recommended to have a step after the calibration step to make adjustments instead of routing the form back. Items to review are below:

See Also

Keywords

success factors, PM, manager comments visible, comments visible, restrict comment visibility, view comments, see comments, comment visibility, CAL, PMGM , KBA , LOD-SF-PM-ADM , Admin Center, RBP, Permissions and Settings , LOD-SF-CAL-PM , Calibrating with Performance Form Data , LOD-SF-PM-CAL , PM-Calibration Issues Specific to PM Forms , Problem

Product

SAP SuccessFactors HCM Suite all versions