Symptom
Field added to the donut chart shows only one common description multiple times, and not the description of each value as expected.
Environment
Cloud for Customer
Reproducing the Issue
- Go to Sales Work Center.
- Go to Opportunity View.
- Enter Adaptation.
- Navigate to the field in the Advanced Search.
- Enable the option "Show In Donut Chart" for "Product Category" Field.
- End Adaptation.
- Select the Query "All".
- Click at Show Donut Chart Icon.
- The field added is visible in donut chart, however it shows only one description multiple times.
*This is just an example, it is valid for other objects and work centers.
Cause
"Cardinality N" fields are not supported in the donut chart (e.g. an opportunity can have N products records with N products categories). So, in the example provided the Product Category field would not be supported.
Resolution
Only fields with 1 cardinality are supported in the donut chart, e.g. status and sales phase fields.
This feature is not supported in the current release of SAP Cloud for Customer.
An alternative option may be to check the SAP Cloud for Customer Customer Influence to submit an idea:
See Also
Keywords
Donut Chart, same description, same legend, same value, only one description, wrong values, wrong description, wrong legend. , KBA , AP-RC-UIF , C4C UI Framework , How To