Symptom
- In the Activities Work Center, SMS messages sent which failed are not logged
- The customer is unable to tell if an SMS message has failed or not
- If an SMS message is sent and then fails, there is no activity created at that time, however, as soon as another message is successfully sent, the system will capture two activities
Image/Data is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP Cloud for Customer
- SAP Cloud for Sales
- SAP Cloud for Service
Reproducing the Issue
- Open a C4C ticket
- Go to the Timeline tab
- Click SMS, screen opens to type SMS
- Select the SMS channel
- Enter To Mobile number (without country code to make it fail)
- Compose a SMS and click send
- Check the timeline and the "Messaging Activities" (notice that no activity was created)
- Repeat above steps (from step 5) again, using the correct "To" number with country code.
- Check the timeline and the Messaging Activities" - notice that 2 Messaging Activity are created, one for SMS sent to number without country code, another SMS sent to number with country code.
Cause
- Technical limitation
- Per standard, the messaging activity is created when the SMS is successfully sent
- If both attempts happened in same session, without closing the feeder (refreshing the ticket), multiple activity creation occurs
- Since the previous failed data still remains in buffer, it will also be saved along with the correct data, therefore creating two successful activities
Resolution
- To prevent such scenarios (multiple activity creation), the user must close the feeder. Two options to close the feeder:
- Option 1: While in the ticket, click the Refresh icon
- Option 2: Exit and re-invoke the ticket, then perform the same steps as before
- Since there is no error displayed in the timeline, another way to tell if the phone number is wrong, users can switch the timeline view to List view, where the recipients number can be seen
For example:
See Also
Keywords
Messaging, SMS, tickets, duplicates, multiple, SMS Channel , KBA , LOD-CRM-SRP , Service Request Processing , LOD-CRM-SRP-INT , Ticket Interactions , Problem
Product
SAP Cloud for Customer core applications 2205