Symptom
Form is in current C-step between E, EM and EX, however the subject has no EX, so the form is only on E and EM Inbox folder.
A new Matrix Manager is added to the Subject via Manage Users, however, the newly added EX does not receive a copy of the form in the Inbox.
Environment
SAP SuccessFactors Performance Management
Reproducing the Issue
- Launch a form for an Employee with no EX;
- Route the form to a C-step between E, EM and EX;
- Add a Matrix Manager to the Subject via Manage Users.
The newly added EX does not receive a copy of the form in the Inbox.
Cause
This is a current system limitation. When adding a new EX via Manage users, the system does not create a new copy of the form for the newly added Matrix Manager, this will only receive a copy of the form when the form is routed to the EX.
Resolution
If there are no future steps for the EX, then a workaround is to route the form back and forth to create the form content for the just added Matrix Manager.
Note: As reporting takes into account what is in the route map, this will also be reflected in reports. The matrix manager will appear in the route map inside the form but they will not receive it until the form is routed to them.
See Also
- 2144428 - Top 10 reasons Forms Are Not Transferring to New Manager or Failed to Route to Manager - Performance Management
- 2078831 - Troubleshooting Document Transfer Options - Performance Management
- 2174247 - Forms Do Not Transfer When Manager is Manually Changed via Employee Profile Manager or Matrix Manager Field - Performance Management
Keywords
c-step, cstep, NO_MANAGER, EX transfer, form transfer, Document Transfer, Matrix Manager , KBA , LOD-SF-PM-MAP , Routing, Route Maps & Workflows , Problem