Symptom
Error "Availability data missing for one or more days in the assignment period" occurs when saving the staffed resource in a work package of customer project.
Environment
SAP S/4HANA Cloud
Reproducing the Issue
- Go to app "Plan Customer Project" and search for the affected project.
- Click into the work package with duration such as 07/01/2022 - 02/01/2023.
- Click button "Add team role" and fill in the role and Effort (planned).
- Click "Add Resource" and choose the resource to staff.
- Click "Save", error occurs.
Cause
- Once scope item 1KC is activated in the system, the user needs to maintain daily availability for the staffed resource.
- After adding team role, the Effort (staffed) will be automatically distributed on average by the month within the work package duration (it will be rounded off if it cannot be divisible).
- Hence, if the daily availability of a staffed resource is not maintained for all these months, an error will occur as "Availability data missing for one or more days in the assignment period".
Resolution
There are 2 resolutions available:
- Maintain the daily availability of resources for all the months between Work Package duration and implement scope item J11 or 1KC to look up "Daily Availability" for the related information. (In case of any further issues regarding daily availability maintenance, create an incident under the component: CA-WFD-INT).
- Click Edit behind the Effort (staffed) and keep the staffed efforts within the months which daily availability of the resources have been maintained.
See Also
2817185 - Resource not shown in the available resources list in the plan customer projects app
Keywords
Plan Customer Project, work package, Add Resource, Resource, Daily Availability, Availability data missing for one or more days in the assignment period, RSH_PROJ_ASG/014 , KBA , CA-CPD-SS , S/4HANA Public Cloud – Professional Service Projects , CA-WFD-INT , S/4HANA Cloud Workforce Domain Integration , CA-TS-S4 , Cross Application Timesheet in S/4HANA , Problem