SAP Knowledge Base Article - Public

3224673 - Activities - How to "Filter by Date" in Advanced Search

Symptom

How to "Filter by Date" in the Advanced Search of Activities. You want to filter activities by a particular date, but when using the "Filter by Date" option in certain fields, the system expects you to enter a specific time.

Environment

SAP Cloud for Customer

Cause

There are different types of fields. Some are 'date/time' fields, others are plain 'date' fields. When using a 'date/time' field, a specific time or time frame needs to be entered.

Resolution

Via Adaptation you can make plain date fields visible. For those, no time specification is needed, the date alone can be selected.

date_time vs date.png

This is the same behaviour in various BOs, for variations of date and date/time fields.

For example, on the Appointments or Phone Calls OWS view: there is, for example, a field called 'Start Date/Time': for this, both date AND time need to be specified when using the "Filter by Date" option. However, for the field 'Start Date', the date alone is required.

Keywords

Filter by Date, Phone call, visit, appointment, activity, activities , KBA , LOD-CRM-OPP , Opportunity Management , Problem

Product

SAP Cloud for Customer core applications 2205