Symptom
Import failed with the below message.
Import.log
=========
[ERROR] 2022-05-23 06:03:28 Cannot import record into the pay period ending on 2022-05-08 for employee: ****** and asgnmt: Embedded Facilitator because the current approval level 94 is above the maximum configured approval level of: 2 import_id=********, detail_record_id=*********, system_record_id=*********
[INFO] 2022-05-23 06:03:28 Saving modified timesheets or schedules
[ERROR] 2022-05-23 06:03:28 Task: *******_SINGLE_CONTROLLER_TIME_IMPORT-E:******* completed with results: *ERROR* Errors prevented some time data from being imported: Commit completed with errors (code:0)
Environment
SAP Time and Attendance Management by WorkForce Software
Reproducing the Issue
Super User logon should be used to run the report for import.
Cause
SULogon was used, so it looks like although PAYADMIN_**** run the jobs who has the role PAYROLL_ADMIN_GENERAL but as Super User feature was used, it can use the approval level of Workforce. That's why current approval level 94 is above the maximum configured approval level of: 2 is thrown.
Resolution
Login as a user with current approval level 94 to run the import successfully.
(Proxying can make the permission level behave strangely)
Keywords
Proxy, Permission, Access level, payadmin, PAYROLL_ADMIN_GENERAL, Super User , KBA , XX-PART-WFR-TAM , SAP Time and Attendance Management by Workforce Software , Problem