SAP Knowledge Base Article - Public

3225164 - Data caching will cause charts not to display fresh data from the backend in SAP Analytics Cloud (SAC)

Symptom

  • When browsing stories in SAP Analytics Cloud (SAC) using HANA Live Data connection, clicking on a bar of a bar chart will cause a getresponse request and trigger the numeric point chart to show the current (minute) date coming from the HANA backend.
    However, once that value is loaded it seems that it gets cached and upon clicking on the same bar will not cause the numeric point chart to update with new data coming from the backend.
  • Users are browsing the story in view mode so it's not easy for them to trigger data actions that would cause new getresponse calls to refresh the value of numeric point charts.

Environment

  • SAP Analytics Cloud FPA Version: 2022.8.14

Reproducing the Issue

  1. Open SAC story based on HANA Live Data Connection in view mode.
  2. Check the initial values based on the numeric point chart.
  3. Now click on the first column of the column bar.
  4. This will trigger getresponse calls with HANA and the numeric point chart will update based on current minute, for example 39.
  5. When waiting 2 more minutes and clicking again on the same column bar, it would be expected to see 41 on the numeric point chart, but it will still display the cached value of 39.
  6. This could cause confusion and incorrect data for the users that are browsing the stories in view mode.

Cause

This issue is currently under investigation by development.

Resolution

This issue is currently under investigation by development.

See Also

Your feedback is important to help us improve our knowledge base.

Keywords

SAC, HANA, story, cache, numeric point chart, no update, value, stuck, refresh , KBA , LOD-ANA-LDC-HAN , SAC Live Data Connection HANA , Problem

Product

SAP Analytics Cloud 1.0